aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/msmtp/msmtp_1.6.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/msmtp/msmtp_1.6.4.bb')
-rw-r--r--meta/recipes-extended/msmtp/msmtp_1.6.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/msmtp/msmtp_1.6.4.bb b/meta/recipes-extended/msmtp/msmtp_1.6.4.bb
new file mode 100644
index 0000000000..fe64184bcb
--- /dev/null
+++ b/meta/recipes-extended/msmtp/msmtp_1.6.4.bb
@@ -0,0 +1,30 @@
+SUMMARY = "msmtp is an SMTP client"
+DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
+HOMEPAGE = "http://msmtp.sourceforge.net/"
+SECTION = "console/network"
+
+LICENSE = "GPLv3"
+DEPENDS = "zlib gnutls"
+
+#COPYING or Licence
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.tar.xz \
+ "
+
+SRC_URI[md5sum] = "aa829b5e9faeca5139f7983e6637f0d6"
+SRC_URI[sha256sum] = "9b49c022a5440d41b6782c97ef2977d0346c3dae05aa8836243a9953e982d1cd"
+
+inherit gettext autotools update-alternatives pkgconfig
+
+EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn"
+
+ALTERNATIVE_${PN} = "sendmail"
+ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
+ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
+ALTERNATIVE_PRIORITY = "100"
+
+pkg_postinst_${PN}_linuxstdbase () {
+ # /usr/lib/sendmial is required by LSB core test
+ [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/
+}