aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ltp/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-Disable-rpc01-on-glibc-and-musl.patch29
-rw-r--r--meta/recipes-extended/ltp/ltp/0004-build-Add-option-to-select-libc-implementation.patch14
2 files changed, 29 insertions, 14 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0001-Disable-rpc01-on-glibc-and-musl.patch b/meta/recipes-extended/ltp/ltp/0001-Disable-rpc01-on-glibc-and-musl.patch
new file mode 100644
index 0000000000..78c6dfb2b1
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-Disable-rpc01-on-glibc-and-musl.patch
@@ -0,0 +1,29 @@
+From ff39e6b69f0b26dad8ab685ee6116ff92bc363db Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 28 Apr 2018 00:08:55 -0700
+Subject: [PATCH] Disable rpc01 on glibc and musl
+
+It is not buildable with libtirpc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ testcases/network/rpc/basic_tests/Makefile | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/testcases/network/rpc/basic_tests/Makefile b/testcases/network/rpc/basic_tests/Makefile
+index 66e9d5675..16a64e7da 100644
+--- a/testcases/network/rpc/basic_tests/Makefile
++++ b/testcases/network/rpc/basic_tests/Makefile
+@@ -23,4 +23,7 @@
+ top_srcdir ?= ../../../..
+
+ include $(top_srcdir)/include/mk/env_pre.mk
++
++FILTER_OUT_DIRS += rpc01
++
+ include $(top_srcdir)/include/mk/generic_trunk_target.mk
+--
+2.17.0
+
diff --git a/meta/recipes-extended/ltp/ltp/0004-build-Add-option-to-select-libc-implementation.patch b/meta/recipes-extended/ltp/ltp/0004-build-Add-option-to-select-libc-implementation.patch
index 84ab37ea39..0781ba1743 100644
--- a/meta/recipes-extended/ltp/ltp/0004-build-Add-option-to-select-libc-implementation.patch
+++ b/meta/recipes-extended/ltp/ltp/0004-build-Add-option-to-select-libc-implementation.patch
@@ -102,20 +102,6 @@ Index: git/testcases/network/nfsv4/acl/Makefile
+endif
+
include $(top_srcdir)/include/mk/generic_leaf_target.mk
-Index: git/testcases/network/rpc/basic_tests/Makefile
-===================================================================
---- git.orig/testcases/network/rpc/basic_tests/Makefile
-+++ git/testcases/network/rpc/basic_tests/Makefile
-@@ -23,4 +23,9 @@
- top_srcdir ?= ../../../..
-
- include $(top_srcdir)/include/mk/env_pre.mk
-+
-+ifeq ($(LIBC),musl)
-+FILTER_OUT_DIRS += rpc01
-+endif
-+
- include $(top_srcdir)/include/mk/generic_trunk_target.mk
Index: git/testcases/realtime/func/pi-tests/Makefile
===================================================================
--- git.orig/testcases/realtime/func/pi-tests/Makefile