aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbtest_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsb/lsbtest_1.0.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
index a877beb299..f61251e2aa 100644
--- a/meta/recipes-extended/lsb/lsbtest_1.0.bb
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -19,15 +19,15 @@ do_install() {
install -d ${D}/opt/lsb-test
install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
install -m 0644 ${S}/session ${D}/opt/lsb-test/session
- if [ "${TARGET_ARCH}" == "i586" ];then
+ if [ "${TARGET_ARCH}" = "i586" ];then
sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
fi
- if [ "${TARGET_ARCH}" == "x86_64" ];then
+ if [ "${TARGET_ARCH}" = "x86_64" ];then
sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
fi
- if [ "${TARGET_ARCH}" == "powerpc" ];then
+ if [ "${TARGET_ARCH}" = "powerpc" ];then
sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
fi
@@ -37,7 +37,7 @@ do_install() {
# in the package_list when MLIB=lib64 is being used.
# Otherwise, by default, the ppc32 LSB packages
# will be downloaded by LSB_Test.sh
- if [ "${TARGET_ARCH}" == "powerpc64" ];then
+ if [ "${TARGET_ARCH}" = "powerpc64" ];then
if [ "${PN}" != "${BPN}" ];then
sed -i -e 's/lsbarch/ppc64/g' -e 's/targetarch/ppc64/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/PPC64/g' ${D}/opt/lsb-test/session