aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libtirpc/libtirpc_0.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libtirpc/libtirpc_0.2.3.bb')
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc_0.2.3.bb35
1 files changed, 31 insertions, 4 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc_0.2.3.bb b/meta/recipes-extended/libtirpc/libtirpc_0.2.3.bb
index ed838b7545..dda9e054d1 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_0.2.3.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_0.2.3.bb
@@ -12,23 +12,50 @@ DEPENDS += "xz-native"
PROVIDES = "virtual/librpc"
SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2;name=libtirpc \
- ${GENTOO_MIRROR}/${BPN}-glibc-nfs.tar.xz;name=glibc-nfs \
file://libtirpc-0.2.1-fortify.patch \
file://obsolete_automake_macros.patch \
+ file://libtirpc-0.2.3-add-missing-bits-from-glibc.patch \
+ file://libtirpc-0.2.3-types.h.patch \
+ file://libtirpc-0008-Add-rpcgen-program-from-nfs-utils-sources.patch \
+ file://key_prot.h \
+ file://nis.h \
+ file://nislib.h \
+ file://nis_tags.h \
+ file://rpc_des.h \
+ file://ypclnt.h \
+ file://yp_prot.h \
"
SRC_URI_append_libc-uclibc = " file://remove-des-uclibc.patch"
SRC_URI[libtirpc.md5sum] = "b70e6c12a369a91e69fcc3b9feb23d61"
SRC_URI[libtirpc.sha256sum] = "4f29ea0491b4ca4c29f95f3c34191b857757873bbbf4b069f9dd4da01a6a923c"
-SRC_URI[glibc-nfs.md5sum] = "5ae500b9d0b6b72cb875bc04944b9445"
-SRC_URI[glibc-nfs.sha256sum] = "2677cfedf626f3f5a8f6e507aed5bb8f79a7453b589d684dbbc086e755170d83"
+
inherit autotools pkgconfig
+CFLAGS += "-I${S}/glibc-headers"
+EXTRA_OECONF = "--disable-gss"
+
do_configure_prepend () {
- cp -r ${S}/../tirpc ${S}
+ install -d ${S}/glibc-headers/rpc/
+ install -d ${S}/glibc-headers/rpcsvc/
+
+ install -m 0644 ${WORKDIR}/key_prot.h ${S}/glibc-headers/rpc
+ install -m 0644 ${WORKDIR}/rpc_des.h ${S}/glibc-headers/rpc
+
+ install -m 0644 ${WORKDIR}/nis.h ${S}/glibc-headers/rpcsvc
+ install -m 0644 ${WORKDIR}/nislib.h ${S}/glibc-headers/rpcsvc
+ install -m 0644 ${WORKDIR}/nis_tags.h ${S}/glibc-headers/rpcsvc
+ install -m 0644 ${WORKDIR}/ypclnt.h ${S}/glibc-headers/rpcsvc
+ install -m 0644 ${WORKDIR}/yp_prot.h ${S}/glibc-headers/rpcsvc
}
do_install_append() {
chown root:root ${D}${sysconfdir}/netconfig
+
+ install -d ${D}/${includedir}/rpc/
+ install -d ${D}/${includedir}/rpcsvc/
+
+ install -m 0644 ${S}/glibc-headers/rpc/*.h ${D}/${includedir}/rpc/
+ install -m 0644 ${S}/glibc-headers/rpcsvc/*.h ${D}/${includedir}/rpcsvc/
}