aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libtirpc/libtirpc-0.2.3/remove-des-uclibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libtirpc/libtirpc-0.2.3/remove-des-uclibc.patch')
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc-0.2.3/remove-des-uclibc.patch45
1 files changed, 18 insertions, 27 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc-0.2.3/remove-des-uclibc.patch b/meta/recipes-extended/libtirpc/libtirpc-0.2.3/remove-des-uclibc.patch
index 4e828f6998..d003348af9 100644
--- a/meta/recipes-extended/libtirpc/libtirpc-0.2.3/remove-des-uclibc.patch
+++ b/meta/recipes-extended/libtirpc/libtirpc-0.2.3/remove-des-uclibc.patch
@@ -3,33 +3,11 @@ uclibc does not provide des functionality unlike eglibc so lets disable ssl supp
Upstream-Status: Inappropriate [uclibc specific]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Index: libtirpc-0.2.2/src/Makefile.am
+Index: libtirpc-0.2.3/src/rpc_soc.c
===================================================================
---- libtirpc-0.2.2.orig/src/Makefile.am 2013-01-23 14:08:58.802143165 -0800
-+++ libtirpc-0.2.2/src/Makefile.am 2013-01-23 18:06:22.970410357 -0800
-@@ -40,7 +40,7 @@
- # release number of your package. This is an abuse that only fosters
- # misunderstanding of the purpose of library versions."
- #
--libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:10:0
-+libtirpc_la_LDFLAGS = -lpthread -version-info 1:10:0
-
- libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
- clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \
-@@ -50,7 +50,7 @@
- rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
- rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_generic.c \
- svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
-- auth_time.c auth_des.c authdes_prot.c
-+ auth_time.c
-
- ## XDR
- libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c
-Index: libtirpc-0.2.2/src/rpc_soc.c
-===================================================================
---- libtirpc-0.2.2.orig/src/rpc_soc.c 2011-05-02 05:10:40.000000000 -0700
-+++ libtirpc-0.2.2/src/rpc_soc.c 2013-01-23 18:07:28.894410317 -0800
-@@ -515,6 +515,7 @@
+--- libtirpc-0.2.3.orig/src/rpc_soc.c 2013-03-10 16:00:51.355282153 -0700
++++ libtirpc-0.2.3/src/rpc_soc.c 2013-03-10 16:00:51.703282148 -0700
+@@ -520,6 +520,7 @@
(resultproc_t) rpc_wrap_bcast, "udp");
}
@@ -37,7 +15,7 @@ Index: libtirpc-0.2.2/src/rpc_soc.c
/*
* Create the client des authentication object. Obsoleted by
* authdes_seccreate().
-@@ -546,6 +547,7 @@
+@@ -551,6 +552,7 @@
dummy = authdes_seccreate(servername, window, NULL, ckey);
return (dummy);
}
@@ -45,3 +23,16 @@ Index: libtirpc-0.2.2/src/rpc_soc.c
/*
* Create a client handle for a unix connection. Obsoleted by clnt_vc_create()
+Index: libtirpc-0.2.3/src/Makefile.am
+===================================================================
+--- libtirpc-0.2.3.orig/src/Makefile.am 2013-03-10 16:00:51.355282153 -0700
++++ libtirpc-0.2.3/src/Makefile.am 2013-03-10 16:00:51.703282148 -0700
+@@ -50,7 +50,7 @@
+ rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
+ rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_auth_none.c \
+ svc_generic.c svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
+- auth_time.c auth_des.c authdes_prot.c
++ auth_time.c
+
+ ## XDR
+ libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c