summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.7.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.7.5.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.7.5.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.7.5.bb b/meta/recipes-extended/libsolv/libsolv_0.7.5.bb
new file mode 100644
index 0000000000..80ce76b45f
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.7.5.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Library for solving packages and reading repositories"
+HOMEPAGE = "https://github.com/openSUSE/libsolv"
+BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
+SECTION = "devel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
+
+DEPENDS = "expat zlib"
+
+SRC_URI = "git://github.com/openSUSE/libsolv.git \
+"
+
+SRCREV = "2cab7ea00d08390374b25b11d969f3740c4660f4"
+
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??= "rpm"
+PACKAGECONFIG[rpm] = "-DENABLE_RPMMD=ON -DENABLE_RPMDB=ON,,rpm"
+
+EXTRA_OECMAKE = "-DMULTI_SEMANTICS=ON -DENABLE_COMPLEX_DEPS=ON"
+
+PACKAGES =+ "${PN}-tools ${PN}ext"
+
+FILES_${PN}-tools = "${bindir}/*"
+FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
+
+BBCLASSEXTEND = "native nativesdk"