aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.4.8.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.4.8.bb b/meta/recipes-extended/iptables/iptables_1.4.8.bb
new file mode 100644
index 0000000000..ad707d30bc
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.4.8.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "iptables is the userspace command line program used to configure the Linux 2.4.x and 2.6.x IPv4 packet filtering ruleset"
+HOMEPAGE = "http://www.netfilter.org/"
+BUGTRACKER = "http://bugzilla.netfilter.org/"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
+ file://iptables.c;firstline=13;endline=25;md5=f1028f2401da1c120df27594b2be50ef"
+
+PR = "r0"
+
+RRECOMMENDS_${PN} = "kernel-module-x-tables \
+ kernel-module-ip-tables \
+ kernel-module-iptable-filter \
+ kernel-module-iptable-nat \
+ kernel-module-nf-defrag-ipv4 \
+ kernel-module-nf-conntrack \
+ kernel-module-nf-conntrack-ipv4 \
+ kernel-module-nf-nat \
+ kernel-module-ipt-masquerade"
+FILES_${PN}-dbg =+ "${libexecdir}/xtables/.debug"
+
+SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}"
+
+do_configure_prepend() {
+ # they are all libtool m4 files
+ rm -rf ${S}/m4
+}