aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/groff')
-rw-r--r--meta/recipes-extended/groff/groff_1.20.1.bb24
1 files changed, 23 insertions, 1 deletions
diff --git a/meta/recipes-extended/groff/groff_1.20.1.bb b/meta/recipes-extended/groff/groff_1.20.1.bb
index 6cb72bf117..ef2254815d 100644
--- a/meta/recipes-extended/groff/groff_1.20.1.bb
+++ b/meta/recipes-extended/groff/groff_1.20.1.bb
@@ -4,7 +4,7 @@ formatting commands and produces formatted output."
SECTION = "base"
HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
@@ -18,6 +18,10 @@ DEPENDS_virtclass-native = ""
inherit autotools
+PERLPATH = "${bindir}/perl"
+PERLPATH_virtclass-native = "/usr/bin/env perl"
+PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
+
EXTRA_OECONF = "--without-x"
PARALLEL_MAKE = ""
@@ -34,7 +38,25 @@ do_configure_prepend() {
fi
}
+do_install_append() {
+ # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+ # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+ for i in afmtodit mmroff; do
+ if [ -f ${D}${bindir}/$i ]; then
+ sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i
+ fi
+ done
+}
+
do_install_append_virtclass-native() {
+ # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+ # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+ for i in afmtodit mmroff; do
+ if [ -f ${D}${bindir}/$i ]; then
+ sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i
+ fi
+ done
+
create_cmdline_wrapper ${D}/${bindir}/groff \
-F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
-M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac