aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.6.bb')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
index 6e160cd3e0..4189f78fdf 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -10,6 +10,7 @@ PR = "r5"
SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
file://configure.ac \
+ file://run-ptest \
file://Makefile.am"
SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
@@ -19,7 +20,7 @@ PACKAGES =+ "libbz2 libbz2-dev libbz2-staticdev"
CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
-inherit autotools update-alternatives
+inherit autotools update-alternatives ptest
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "bunzip2 bzcat"
@@ -32,6 +33,10 @@ do_configure_prepend () {
cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
}
+do_install_ptest () {
+ sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
+}
+
FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
FILES_libbz2-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV}"