aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/0001-update-alternatives-avoid-double-slashes.patch25
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/0001-update-alternatives-avoid-double-slashes.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/0001-update-alternatives-avoid-double-slashes.patch
new file mode 100644
index 0000000000..a63b26b4e5
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/0001-update-alternatives-avoid-double-slashes.patch
@@ -0,0 +1,25 @@
+Upstream-Status: Pending
+
+Subject: update-alternatives: avoid double slashes
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ update-alternatives | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/update-alternatives b/update-alternatives
+index 8916cbd..ca01d5d 100644
+--- a/update-alternatives
++++ b/update-alternatives
+@@ -97,7 +97,7 @@ find_best_alt() {
+ [ $# -lt 1 ] && return 1
+ [ ! -f $ad/$name ] && return 0
+
+- link=$OPKG_OFFLINE_ROOT/`head -n 1 $ad/$name`
++ link=$OPKG_OFFLINE_ROOT`head -n 1 $ad/$name`
+
+ prio=`sed -ne "1!p" $ad/$name | sed -e "s/\(.*\) \(.*\)/\2 \1/g" | sort -nr | head -n 1 | sed 's/ [^ ]*$//'`
+ if [ -z "$prio" ]; then
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 72dc98e2fc..1c9a3b5c97 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -10,7 +10,8 @@ PROVIDES += "virtual/update-alternatives"
SRCREV = "762d9dadce548108d4204c2113461a7dd6f57e60"
PV = "0.1.8+git${SRCPV}"
-SRC_URI = "git://git.yoctoproject.org/opkg-utils"
+SRC_URI = "git://git.yoctoproject.org/opkg-utils \
+ file://0001-update-alternatives-avoid-double-slashes.patch"
S = "${WORKDIR}/git"