aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl/no_packages.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl/no_packages.patch')
-rw-r--r--meta/recipes-devtools/tcltk/tcl/no_packages.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl/no_packages.patch b/meta/recipes-devtools/tcltk/tcl/no_packages.patch
new file mode 100644
index 0000000000..b045814589
--- /dev/null
+++ b/meta/recipes-devtools/tcltk/tcl/no_packages.patch
@@ -0,0 +1,53 @@
+tcl 8.6.0 builds by default a number of packages that are not needed in Yocto.
+This patch changes the makefile so that these packages are not built by default.
+
+Upstream-Status:Inappropriate [embedded specific]
+
+Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com>
+
+diff --git unix.orig/Makefile.in unix/Makefile.in
+index 16351f6..76ccadb 100644
+--- unix.orig/Makefile.in
++++ unix/Makefile.in
+@@ -601,7 +601,7 @@ SRCS = $(GENERIC_SRCS) $(TOMMATH_SRCS) $(UNIX_SRCS) $(NOTIFY_SRCS) \
+ # Start of rules
+ #--------------------------------------------------------------------------
+
+-all: binaries libraries doc packages
++all: binaries libraries doc
+
+ binaries: ${LIB_FILE} $(STUB_LIB_FILE) ${TCL_EXE}
+
+@@ -646,12 +646,12 @@ Makefile: $(UNIX_DIR)/Makefile.in $(DLTEST_DIR)/Makefile.in
+ #tclConfig.h: $(UNIX_DIR)/tclConfig.h.in
+ # $(SHELL) config.status
+
+-clean: clean-packages
++clean:
+ rm -f *.a *.o libtcl* core errs *~ \#* TAGS *.E a.out \
+ errors ${TCL_EXE} ${TCLTEST_EXE} lib.exp Tcl @DTRACE_HDR@
+ cd dltest ; $(MAKE) clean
+
+-distclean: distclean-packages clean
++distclean: clean
+ rm -rf Makefile config.status config.cache config.log tclConfig.sh \
+ tclConfig.h *.plist Tcl.framework tcl.pc
+ cd dltest ; $(MAKE) distclean
+@@ -699,7 +699,7 @@ tcltest-real:
+ # tcltest, ie:
+ # % make test TESTFLAGS="-verbose bps -file fileName.test"
+
+-test: test-tcl test-packages
++test: test-tcl
+
+ test-tcl: ${TCLTEST_EXE}
+ $(SHELL_ENV) ${TCLTEST_EXE} $(TOP_DIR)/tests/all.tcl $(TESTFLAGS)
+@@ -764,7 +764,7 @@ INSTALL_PACKAGE_TARGETS = install-packages
+ INSTALL_DEV_TARGETS = install-headers
+ INSTALL_EXTRA_TARGETS = @EXTRA_INSTALL@
+ INSTALL_TARGETS = $(INSTALL_BASE_TARGETS) $(INSTALL_DOC_TARGETS) $(INSTALL_DEV_TARGETS) \
+- $(INSTALL_PACKAGE_TARGETS) $(INSTALL_EXTRA_TARGETS)
++ $(INSTALL_EXTRA_TARGETS)
+
+ install: $(INSTALL_TARGETS)
+