aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/subversion/subversion-1.5.5
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/subversion/subversion-1.5.5')
-rw-r--r--meta/recipes-devtools/subversion/subversion-1.5.5/disable-revision-install.patch22
-rw-r--r--meta/recipes-devtools/subversion/subversion-1.5.5/libtool2.patch15
-rw-r--r--meta/recipes-devtools/subversion/subversion-1.5.5/neon-detection.patch36
3 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion-1.5.5/disable-revision-install.patch b/meta/recipes-devtools/subversion/subversion-1.5.5/disable-revision-install.patch
new file mode 100644
index 0000000000..a1c60654cb
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion-1.5.5/disable-revision-install.patch
@@ -0,0 +1,22 @@
+--- subversion-1.2.0-r0/Makefile.in.old 2005-07-17 22:28:21.898728312 +0200
++++ subversion-1.2.0-r0/Makefile.in 2005-07-17 22:30:05.361999504 +0200
+@@ -260,7 +260,7 @@
+ clean: external-clean local-clean
+ distclean: external-distclean local-distclean
+ extraclean: external-extraclean local-extraclean
+-install: external-install local-install revision-install
++install: external-install local-install #revision-install
+
+ @INCLUDE_OUTPUTS@
+
+@@ -320,8 +320,8 @@
+ local-install: @INSTALL_RULES@
+
+ ### HACK!! Find a better way to do this
+-revision-install:
+- subversion/svnversion/svnversion $(top_srcdir) /repos/svn/trunk > $(DESTDIR)$(includedir)/subversion-1/svn-revision.txt
++#revision-install:
++# subversion/svnversion/svnversion $(top_srcdir) /repos/svn/trunk > $(DESTDIR)$(includedir)/subversion-1/svn-revision.txt
+
+ install-static: @INSTALL_STATIC_RULES@
+
diff --git a/meta/recipes-devtools/subversion/subversion-1.5.5/libtool2.patch b/meta/recipes-devtools/subversion/subversion-1.5.5/libtool2.patch
new file mode 100644
index 0000000000..08343b09ec
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion-1.5.5/libtool2.patch
@@ -0,0 +1,15 @@
+Index: subversion-1.5.5/configure.ac
+===================================================================
+--- subversion-1.5.5.orig/configure.ac 2008-08-26 18:27:56.000000000 +0100
++++ subversion-1.5.5/configure.ac 2009-01-07 18:00:47.000000000 +0000
+@@ -153,8 +153,8 @@
+ LIBTOOL="$sh_libtool"
+ SVN_LIBTOOL="$sh_libtool"
+ else
+- sh_libtool="$abs_builddir/libtool"
+- SVN_LIBTOOL="\$(SHELL) $sh_libtool"
++ sh_libtool="$abs_builddir/$host_alias-libtool"
++ SVN_LIBTOOL="\$(SHELL) \$(abs_builddir)/$host_alias-libtool"
+ dnl libtoolize requires that the following line not be indented
+ ifdef([LT_INIT], [LT_INIT], [AC_PROG_LIBTOOL])
+ fi
diff --git a/meta/recipes-devtools/subversion/subversion-1.5.5/neon-detection.patch b/meta/recipes-devtools/subversion/subversion-1.5.5/neon-detection.patch
new file mode 100644
index 0000000000..b567d5c050
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion-1.5.5/neon-detection.patch
@@ -0,0 +1,36 @@
+diff --git a/build/ac-macros/neon.m4 b/build/ac-macros/neon.m4
+index 9fcf859..8d964f3 100644
+--- a/build/ac-macros/neon.m4
++++ b/build/ac-macros/neon.m4
+@@ -38,7 +38,7 @@ AC_DEFUN(SVN_LIB_NEON,
+ if test "$withval" = "yes" ; then
+ AC_MSG_ERROR([--with-neon requires an argument.])
+ else
+- neon_config="$withval/bin/neon-config"
++ neon_config="env env PKG_CONFIG_PATH=${withval}:${PKG_CONFIG_PATH} pkg-config neon"
+ fi
+
+ SVN_NEON_CONFIG()
+@@ -117,10 +117,10 @@ dnl SVN_NEON_CONFIG()
+ dnl neon-config found, gather relevant information from it
+ AC_DEFUN(SVN_NEON_CONFIG,
+ [
+- if test -f "$neon_config"; then
+- if test "$neon_config" != ""; then
++ if true; then
++ if true; then
+ AC_MSG_CHECKING([neon library version])
+- NEON_VERSION=`$neon_config --version | sed -e 's/^neon //'`
++ NEON_VERSION=`$neon_config --modversion | sed -e 's/^neon //'`
+ AC_MSG_RESULT([$NEON_VERSION])
+
+ if test -n "`echo \"$NEON_VERSION\" | grep '^0\.25\.'`" ; then
+@@ -133,7 +133,7 @@ AC_DEFUN(SVN_NEON_CONFIG,
+ test "$svn_allowed_neon" = "any"; then
+ svn_allowed_neon_on_system="yes"
+ SVN_NEON_INCLUDES=[`$neon_config --cflags | sed -e 's/-D[^ ]*//g'`]
+- NEON_LIBS=`$neon_config --la-file`
++ NEON_LIBS=`$neon_config --libs`
+ CFLAGS=["$CFLAGS `$neon_config --cflags | sed -e 's/-I[^ ]*//g'`"]
+ svn_lib_neon="yes"
+ break