aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.8.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.8.bb b/meta/recipes-devtools/strace/strace_4.8.bb
index 0f4d2f001e..79a4ad79ab 100644
--- a/meta/recipes-devtools/strace/strace_4.8.bb
+++ b/meta/recipes-devtools/strace/strace_4.8.bb
@@ -7,11 +7,16 @@ PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
file://git-version-gen \
- file://strace-add-configure-options.patch"
+ file://strace-add-configure-options.patch \
+ file://Makefile-ptest.patch \
+ file://run-ptest \
+ "
SRC_URI[md5sum] = "c575ef43829586801f514fd91bfe7575"
SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8"
-inherit autotools
+
+inherit autotools ptest
+RDEPENDS_${PN}-ptest += "make"
PACKAGECONFIG_class-target ?= "libaio"
PACKAGECONFIG_class-target += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
@@ -21,6 +26,8 @@ PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
export INCLUDES = "-I. -I./linux"
+TESTDIR = "tests"
+
do_configure_prepend() {
cp ${WORKDIR}/git-version-gen ${S}
}
@@ -30,4 +37,12 @@ do_install_append() {
rm ${D}${bindir}/strace-graph
}
+do_compile_ptest() {
+ oe_runmake -C ${TESTDIR} buildtest-TESTS
+}
+
+do_install_ptest() {
+ oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
+}
+
BBCLASSEXTEND = "native"