aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-uuid-include.patch35
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-uuid-include.patch b/meta/recipes-devtools/rpm/rpm/rpm-uuid-include.patch
new file mode 100644
index 0000000000..0e45ed78ff
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-uuid-include.patch
@@ -0,0 +1,35 @@
+A patch to fix a problem when compiling with uuid.
+
+When attempting to build with uuid and all tests compiling will error because
+uuid.h doesn't exist in the rpm tarball. Fix this by changing the include to
+use the one in ossp which solves the issue.
+
+The recipe already depends on ossp so ossp/uuid.h will be there when rpm-native
+is built.
+
+Signed-off-by: Morgan Little <morgan.little@windriver.com>
+
+
+--- a/lua/local/luuid.c.orig
++++ b/lua/local/luuid.c
+@@ -21,7 +21,7 @@
+
+ #ifdef LUA_USE_UUID
+
+-#include "uuid.h"
++#include <ossp/uuid.h>
+
+ /* Lua method: <uuid> = uuid.generate(<version>[, <uuid-namespace>, <data>]) */
+ static int luuid_generate(lua_State *L)
+
+--- a/rpmio/rpmuuid.c.orig
++++ b/rpmio/rpmuuid.c
+@@ -16,7 +16,7 @@
+ #include "rpmlog.h"
+ #include "rpmuuid.h"
+ #ifdef WITH_UUID
+-#include "uuid.h"
++#include <ossp/uuid.h>
+ #endif
+ #include "debug.h"
+
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index 54354457b6..2a4c8d831c 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -43,7 +43,7 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "libpcre attr acl popt ossp-uuid file bison-native"
-PR = "r48"
+PR = "r49"
# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
# in order to extract the distribution SRPM into a format we can extract...
@@ -76,6 +76,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.9-0.20120508.src.rpm;ex
file://rpmatch.patch \
file://fstack-protector-configure-check.patch \
file://dbconvert.patch \
+ file://rpm-uuid-include.patch \
"
SRC_URI[md5sum] = "60d56ace884340c1b3fcac6a1d58e768"