aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch b/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
index dd8d8bd5de..cb85bebfc0 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
@@ -3,17 +3,17 @@ Upstream-Status: Pending
Author: Khem Raj <raj.khem@gmail.com>
Date: 2011-03-03
Description:
-This patch fixes build issue found when compiling rpm-natibe on ubuntu
+This patch fixes build issue found when compiling rpm-native on ubuntu
11.04-alpha. Problem is that linker does not get correct set of dependent
libraries when linking mtree binary which results in undefined symbols
in librpmio.so. This patch adds correct flags to mtree_LDADD to account
for rpmio deps
-Index: rpm-5.4.0/tools/Makefile.am
+Index: rpm-5.4.14/tools/Makefile.am
===================================================================
---- rpm-5.4.0.orig/tools/Makefile.am
-+++ rpm-5.4.0/tools/Makefile.am
-@@ -169,7 +169,7 @@ grep_LDADD = $(RPMIO_LDADD_COMMON)
+--- rpm-5.4.14.orig/tools/Makefile.am
++++ rpm-5.4.14/tools/Makefile.am
+@@ -186,7 +186,7 @@ grep_LDADD = $(RPMIO_LDADD_COMMON)
mtree_SOURCES = rpmmtree.c
mtree_LDFLAGS = @LDFLAGS_STATIC@ $(LDFLAGS)