aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/quilt/quilt/patch-version-detection.patch')
-rw-r--r--meta/recipes-devtools/quilt/quilt/patch-version-detection.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch b/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch
new file mode 100644
index 0000000000..8b84f812b5
--- /dev/null
+++ b/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch
@@ -0,0 +1,29 @@
+From: Jean Delvare
+Subject: [Quilt-dev] [PACH] Fix patch version detection
+Date: Mon, 21 Jun 2010 13:49:50 +0200
+
+New versions of GNU patch present themselves as "GNU patch" instead
+of just "patch".
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -262,7 +262,11 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version
+
+--
+Jean Delvare
+Suse L3