aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python.inc4
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.0.bb3
-rw-r--r--meta/recipes-devtools/python/python3_3.5.0.bb3
3 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python.inc b/meta/recipes-devtools/python/python.inc
index 4d428f3d07..878f5826be 100644
--- a/meta/recipes-devtools/python/python.inc
+++ b/meta/recipes-devtools/python/python.inc
@@ -12,6 +12,10 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz"
SRC_URI[md5sum] = "38d530f7efc373d64a8fb1637e3baaa7"
SRC_URI[sha256sum] = "90d27e14ea7e03570026850e2e50ba71ad20b7eb31035aada1cf3def8f8d4916"
+# python recipe is actually python 2.x
+# also, exclude pre-releases for both python 2.x and 3.x
+UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>2(\.\d+)+).tar"
+
PYTHON_MAJMIN = "2.7"
inherit autotools
diff --git a/meta/recipes-devtools/python/python3-native_3.5.0.bb b/meta/recipes-devtools/python/python3-native_3.5.0.bb
index 198f93d1bf..0dd165019f 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.0.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.0.bb
@@ -31,6 +31,9 @@ SRC_URI[sha256sum] = "d6d7aa1634a5eeeca6ed4fca266982a04f84bd8f3945a9179e20b24ad2
LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
+# exclude pre-releases for both python 2.x and 3.x
+UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
+
S = "${WORKDIR}/Python-${PV}"
EXTRANATIVEPATH += "bzip2-native"
diff --git a/meta/recipes-devtools/python/python3_3.5.0.bb b/meta/recipes-devtools/python/python3_3.5.0.bb
index 2475dba1fc..7f6fbdb27c 100644
--- a/meta/recipes-devtools/python/python3_3.5.0.bb
+++ b/meta/recipes-devtools/python/python3_3.5.0.bb
@@ -41,6 +41,9 @@ SRC_URI += "\
SRC_URI[md5sum] = "d149d2812f10cbe04c042232e7964171"
SRC_URI[sha256sum] = "d6d7aa1634a5eeeca6ed4fca266982a04f84bd8f3945a9179e20b24ad2e2be91"
+# exclude pre-releases for both python 2.x and 3.x
+UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
+
LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
S = "${WORKDIR}/Python-${PV}"