summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbusmock_0.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbusmock_0.24.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbusmock_0.24.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbusmock_0.24.0.bb b/meta/recipes-devtools/python/python3-dbusmock_0.24.0.bb
new file mode 100644
index 0000000000..271a2b105f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbusmock_0.24.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
+HOMEPAGE = "https://pypi.org/project/python-dbusmock/"
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI[sha256sum] = "0be0d51dba4aee050bb2cd9074a377bf9308306df1eb7918038c6ffe7153c272"
+
+PYPI_PACKAGE = "python-dbusmock"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-dbus \
+ ${PYTHON_PN}-pygobject \
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+ "