aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.24.0.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.24.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.24.0.bb b/meta/recipes-devtools/perl/perl-native_5.24.0.bb
index af2ad7b510..42162574b0 100644
--- a/meta/recipes-devtools/perl/perl-native_5.24.0.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.24.0.bb
@@ -106,6 +106,10 @@ do_install () {
for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
done
+
+ # The packlist is large with hardcoded paths meaning it needs relocating
+ # so just remove it.
+ rm ${D}${libdir}/perl/${PV}/.packlist
}
SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"