summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/meson/meson_0.44.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/meson/meson_0.44.0.bb')
-rw-r--r--meta/recipes-devtools/meson/meson_0.44.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/meson/meson_0.44.0.bb b/meta/recipes-devtools/meson/meson_0.44.0.bb
new file mode 100644
index 0000000000..9b4c7e6ab1
--- /dev/null
+++ b/meta/recipes-devtools/meson/meson_0.44.0.bb
@@ -0,0 +1,20 @@
+HOMEPAGE = "http://mesonbuild.com"
+SUMMARY = "A high performance build system"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "https://github.com/mesonbuild/meson/releases/download/${PV}/${BP}.tar.gz \
+ file://0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch \
+ file://0002-gobject-introspection-determine-g-ir-scanner-and-g-i.patch \
+ file://0001-Linker-rules-move-cross_args-in-front-of-output_args.patch \
+ "
+SRC_URI[md5sum] = "26a7ca93ec9cea5facb365664261f9c6"
+SRC_URI[sha256sum] = "50f9b12b77272ef6ab064d26b7e06667f07fa9f931e6a20942bba2216ba4281b"
+UPSTREAM_CHECK_URI = "https://github.com/mesonbuild/meson/releases"
+
+inherit setuptools3
+
+RDEPENDS_${PN} = "ninja python3-core python3-modules"
+
+BBCLASSEXTEND = "native"