summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/llvm')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 2a8cd4a3e4..01a7da8ebd 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -19,18 +19,14 @@ PROVIDES += "llvm${PV}"
LLVM_RELEASE = "${PV}"
LLVM_DIR = "llvm${LLVM_RELEASE}"
-# SRCREV is set to the revision of 8.0.0-rc2 tag, while latest release
-# tag is 7.0.1 as of Feb 18 2019, hence the need for UPSTREAM_CHECK_UNKNOWN
-# Remove the UPSTREAM_VERSION_UNKNOWN line once 8.0.0 final is tagged
-UPSTREAM_VERSION_UNKNOWN = "1"
-SRCREV = "98ebe7460199b9cd79eb562b5e8705ad28f5513f"
+SRCREV = "d2298e74235598f15594fe2c99bbac870a507c59"
BRANCH = "release/${MAJOR_VERSION}.x"
MAJOR_VERSION = "8"
MINOR_VERSION = "0"
PATCH_VERSION = "0"
SOLIBVER = "1"
-PV = "${MAJOR_VERSION}.${MINOR_VERSION}"
+PV = "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}"
SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
file://0002-llvm-allow-env-override-of-exe-path.patch \