aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-native_2.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-native_2.4.5.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.5.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.5.bb
new file mode 100644
index 0000000000..4c5218ade0
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.5.bb
@@ -0,0 +1,22 @@
+require libtool-${PV}.inc
+
+DEPENDS = ""
+
+SRC_URI += "file://prefix.patch"
+
+inherit native
+
+EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
+
+do_configure_prepend () {
+ # Remove any existing libtool m4 since old stale versions would break
+ # any upgrade
+ rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
+ rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
+}