aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/help2man/help2man-native_1.47.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/help2man/help2man-native_1.47.6.bb')
-rw-r--r--meta/recipes-devtools/help2man/help2man-native_1.47.6.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man-native_1.47.6.bb b/meta/recipes-devtools/help2man/help2man-native_1.47.6.bb
new file mode 100644
index 0000000000..794d308cb7
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man-native_1.47.6.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Program for creating simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+DEPENDS = "autoconf-native automake-native"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "7424901e6eca8af372d2ad62be5cf659"
+SRC_URI[sha256sum] = "d91b0295b72a638e4a564f643e4e6d1928779131f628c00f356c13bf336de46f"
+
+inherit autotools native
+
+EXTRA_OECONF = "--disable-nls"
+
+# We don't want to reconfigure things as it would require 'perlnative' to be
+# used.
+do_configure() {
+ oe_runconf
+}
+
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}