aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/help2man/help2man-native_1.47.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/help2man/help2man-native_1.47.1.bb')
-rw-r--r--meta/recipes-devtools/help2man/help2man-native_1.47.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man-native_1.47.1.bb b/meta/recipes-devtools/help2man/help2man-native_1.47.1.bb
new file mode 100644
index 0000000000..bc6d50eb3d
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man-native_1.47.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Program for creating simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+DEPENDS = "autoconf-native automake-native"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "cf7aaaeea40bff1176df825430694173"
+SRC_URI[sha256sum] = "c59b26f60cb06e45b00e729dea721e7a17220e2c17d800eb428271a750382b06"
+
+inherit autotools native
+
+EXTRA_OECONF = "--disable-nls"
+
+# We don't want to reconfigure things as it would require 'perlnative' to be
+# used.
+do_configure() {
+ oe_runconf
+}
+
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}