summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/help2man/help2man-native_1.41.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/help2man/help2man-native_1.41.2.bb')
-rw-r--r--meta/recipes-devtools/help2man/help2man-native_1.41.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man-native_1.41.2.bb b/meta/recipes-devtools/help2man/help2man-native_1.41.2.bb
new file mode 100644
index 0000000000..7149c4cb90
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man-native_1.41.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Program to create simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+DEPENDS = "autoconf-native automake-native"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "48cb7fa1d9cca2ebea1844694668c8a8"
+SRC_URI[sha256sum] = "6a8c94cde314fdfd1e9e397eeebf2c57b0603c8cc2a2ec9228c7778e1a0940ab"
+
+inherit autotools native
+
+EXTRA_OECONF = "--disable-nls"
+
+# We don't want to reconfigure things as it would require 'perlnative' to be
+# used.
+do_configure() {
+ oe_runconf
+}
+
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}