aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file_5.17.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.17.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.17.bb b/meta/recipes-devtools/file/file_5.17.bb
new file mode 100644
index 0000000000..4ed0820541
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.17.bb
@@ -0,0 +1,36 @@
+SUMMARY = "File classification tool"
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+HOMEPAGE = "http://www.darwinsys.com/file/"
+SECTION = "console/utils"
+
+# two clause BSD
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
+
+DEPENDS = "zlib file-native"
+DEPENDS_class-native = "zlib-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
+ file://dump \
+ file://filesystems"
+
+SRC_URI[md5sum] = "e19c47e069ced7b01ccb4db402cc01d3"
+SRC_URI[sha256sum] = "3feb97141b387b64da30aee485852925312c0e74219380a5ed451f14a90c83ca"
+
+inherit autotools
+
+do_configure_prepend() {
+ cp ${WORKDIR}/dump ${S}/magic/Magdir/
+ cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
+}
+
+FILES_${PN} += "${datadir}/misc/*.mgc"
+
+do_install_append_class-native() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
+
+
+BBCLASSEXTEND = "native nativesdk"