aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dpkg/dpkg.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dpkg/dpkg.inc')
-rw-r--r--meta/recipes-devtools/dpkg/dpkg.inc51
1 files changed, 47 insertions, 4 deletions
diff --git a/meta/recipes-devtools/dpkg/dpkg.inc b/meta/recipes-devtools/dpkg/dpkg.inc
index 3b45bfb31c..14d7b9c68b 100644
--- a/meta/recipes-devtools/dpkg/dpkg.inc
+++ b/meta/recipes-devtools/dpkg/dpkg.inc
@@ -57,16 +57,59 @@ do_install_append () {
fi
}
-PACKAGES =+ "update-alternatives-dpkg"
+PACKAGES =+ "dpkg-perl dselect libdpkg-perl update-alternatives-dpkg"
RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} run-postinsts"
RDEPENDS_${PN}_class-native = ""
+RSUGGESTS_${PN} = "apt"
+
+RDEPENDS_dpkg-perl = "binutils libdpkg-perl make xz"
+RRECOMMENDS_dpkg-perl = "gnupg gpgv"
+
+RDEPENDS_dselect = "dpkg"
+RSUGGESTS_dselect = "perl"
+
+RDEPENDS_libdpkg-perl = "dpkg libtimedate-perl perl"
+RRECOMMENDS_libdpkg-perl = "xz"
+RSUGGESTS_libdpkg-perl = "binutils gnupg gpgv"
-FILES_update-alternatives-dpkg = "${bindir}/update-alternatives ${localstatedir}/lib/dpkg/alternatives ${sysconfdir}/alternatives"
RPROVIDES_update-alternatives-dpkg = "update-alternatives"
RCONFLICTS_update-alternatives-dpkg = "update-alternatives"
-PACKAGES += "${PN}-perl"
-FILES_${PN}-perl = "${libdir}/perl"
+FILES_dpkg-perl = " \
+ ${bindir}/dpkg-architecture \
+ ${bindir}/dpkg-buildflags \
+ ${bindir}/dpkg-buildpackage \
+ ${bindir}/dpkg-checkbuilddeps \
+ ${bindir}/dpkg-distaddfile \
+ ${bindir}/dpkg-genchanges \
+ ${bindir}/dpkg-gencontrol \
+ ${bindir}/dpkg-gensymbols \
+ ${bindir}/dpkg-mergechangelogs \
+ ${bindir}/dpkg-name \
+ ${bindir}/dpkg-parsechangelog \
+ ${bindir}/dpkg-scanpackages \
+ ${bindir}/dpkg-scansources \
+ ${bindir}/dpkg-shlibdeps \
+ ${bindir}/dpkg-source \
+ ${bindir}/dpkg-vendor \
+ ${datadir}/dpkg/*.mk \
+"
+
+FILES_dselect = "${bindir}/dselect"
+
+FILES_libdpkg-perl = " \
+ ${libdir}/dpkg/parsechangelog \
+ ${libdir}/perl \
+"
+
+FILES_update-alternatives-dpkg = " \
+ ${sysconfdir}/alternatives \
+ ${bindir}/update-alternatives \
+ ${localstatedir}/lib/dpkg/alternatives \
+"
+
+PKG_dpkg-dev = "libdpkg-dev"
+PKG_dpkg-perl = "dpkg-dev"
BBCLASSEXTEND = "native"