aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb5
-rw-r--r--meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch17
2 files changed, 21 insertions, 1 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
index 08b2c02641..d032cb97e0 100644
--- a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
@@ -4,7 +4,10 @@ inherit native
# Using cmake's internal libarchive, so some dependencies are needed
DEPENDS += "bzip2-native zlib-native"
-SRC_URI += "file://cmlibarchive-disable-ext2fs.patch"
+SRC_URI += "\
+ file://cmlibarchive-disable-ext2fs.patch \
+ file://disable-bootstrap-cursesdialog.patch \
+"
SRC_URI[md5sum] = "17c6513483d23590cbce6957ec6d1e66"
SRC_URI[sha256sum] = "8c6574e9afabcb9fc66f463bb1f2f051958d86c85c37fccf067eb1a44a120e5e"
diff --git a/meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch b/meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch
new file mode 100644
index 0000000000..9d378fb24c
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch
@@ -0,0 +1,17 @@
+Disable building CursesDialog so that cmake-native doesn't have to
+depend on ncurses-native.
+
+Upstream-status: Inappropriate [disable feature]
+
+Signed-off-by: Mike Crowe <mac@mcrowe.com>
+
+--- cmake-2.8.12.2/bootstrap~ 2014-01-16 17:15:09.000000000 +0000
++++ cmake-2.8.12.2/bootstrap 2014-04-01 21:27:23.841996822 +0100
+@@ -1578,6 +1578,7 @@ export MAKE
+
+ # Run bootstrap CMake to configure real CMake
+ cmake_options="-DCMAKE_BOOTSTRAP=1"
++cmake_options="${cmake_options} -DBUILD_CursesDialog=0"
+ if [ -n "${cmake_verbose}" ]; then
+ cmake_options="${cmake_options} -DCMAKE_VERBOSE_MAKEFILE=1"
+ fi