aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.6.1.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.6.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb b/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
new file mode 100644
index 0000000000..33930fbb9c
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
@@ -0,0 +1,18 @@
+require cmake.inc
+inherit native
+
+# Using cmake's internal libarchive, so some dependencies are needed
+DEPENDS += "bzip2-native zlib-native"
+
+SRC_URI += "\
+ file://cmlibarchive-disable-ext2fs.patch \
+"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DBUILD_CursesDialog=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_compile[progress] = "percent"