summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_4.3.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.3.bb b/meta/recipes-devtools/ccache/ccache_4.3.bb
new file mode 100644
index 0000000000..53a0bcf7ae
--- /dev/null
+++ b/meta/recipes-devtools/ccache/ccache_4.3.bb
@@ -0,0 +1,25 @@
+SUMMARY = "a fast C/C++ compiler cache"
+DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
+by caching the result of previous compilations and detecting when the \
+same compilation is being done again. Supported languages are C, C\+\+, \
+Objective-C and Objective-C++."
+HOMEPAGE = "http://ccache.samba.org"
+SECTION = "devel"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=698a26b57e513d678e1e7727bf56395b"
+
+DEPENDS = "zstd"
+
+SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "b9789c42e52c73e99428f311a34def9ffec3462736439afd12dbacc7987c1533"
+
+UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
+
+inherit cmake
+
+PATCHTOOL = "patch"
+
+BBCLASSEXTEND = "native nativesdk"
+
+PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"