summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake.inc')
-rw-r--r--meta/recipes-devtools/automake/automake.inc9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-devtools/automake/automake.inc b/meta/recipes-devtools/automake/automake.inc
index a1debd8d53..9946c73c71 100644
--- a/meta/recipes-devtools/automake/automake.inc
+++ b/meta/recipes-devtools/automake/automake.inc
@@ -1,7 +1,7 @@
SUMMARY = "A GNU tool for automatically generating Makefiles"
DESCRIPTION = "Automake is a tool for automatically generating `Makefile.in' files compliant with the GNU Coding \
Standards. Automake requires the use of Autoconf."
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
HOMEPAGE = "http://www.gnu.org/software/automake/"
SECTION = "devel"
@@ -10,9 +10,12 @@ SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.gz"
inherit autotools texinfo
do_configure() {
+ # We can end up patching macros, which would then mean autoreconf
+ # Cheat by saying everything is up to date.
+ touch ${S}/aclocal.m4 ${S}/Makefile.in ${S}/configure
oe_runconf
}
-export AUTOMAKE = "${@bb.utils.which('automake', d.getVar('PATH', True))}"
+export AUTOMAKE = "${@bb.utils.which('automake', d.getVar('PATH'))}"
-FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+FILES:${PN} += "${datadir}/automake* ${datadir}/aclocal*"