aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units.bb19
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service17
2 files changed, 1 insertions, 35 deletions
diff --git a/meta/recipes-core/systemd/systemd-compat-units.bb b/meta/recipes-core/systemd/systemd-compat-units.bb
index d8cc3f7852..e653470821 100644
--- a/meta/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta/recipes-core/systemd/systemd-compat-units.bb
@@ -9,17 +9,7 @@ DEPENDS = "systemd-systemctl-native"
inherit allarch
-SRC_URI = "file://*.service"
-
-do_install() {
- install -d ${D}${systemd_unitdir}/system/basic.target.wants
- install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
- sed -i -e 's,@POSTINSTALL_INITPOSITION@,${POSTINSTALL_INITPOSITION},g' \
- ${WORKDIR}/run-postinsts.service
- install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system
- ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/basic.target.wants/
- ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
-}
+ALLOW_EMPTY_${PN} = "1"
SYSTEMD_DISABLED_SYSV_SERVICES = " \
busybox-udhcpc \
@@ -47,11 +37,4 @@ pkg_postinst_${PN} () {
done ; echo
}
-FILES_${PN} = "${systemd_unitdir}/system ${bindir}"
RDPEPENDS_${PN} = "systemd"
-
-# Define a variable to allow distros to run configure earlier.
-# (for example, to enable loading of ethernet kernel modules before networking starts)
-# note: modifying name or default value for POSTINSTALL_INITPOSITION requires
-# changes in opkg.inc
-POSTINSTALL_INITPOSITION ?= "98"
diff --git a/meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service b/meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service
deleted file mode 100644
index 35cf3d32de..0000000000
--- a/meta/recipes-core/systemd/systemd-compat-units/run-postinsts.service
+++ /dev/null
@@ -1,17 +0,0 @@
-[Unit]
-Description=Run pending postinsts
-DefaultDependencies=no
-ConditionPathExists=|/etc/rcS.d/S@POSTINSTALL_INITPOSITION@run-postinsts
-After=systemd-remount-fs.service systemd-tmpfiles-setup.service tmp.mount
-Before=sysinit.target
-
-[Service]
-ExecStart=/etc/rcS.d/S@POSTINSTALL_INITPOSITION@run-postinsts
-RemainAfterExit=No
-Type=oneshot
-StandardOutput=syslog
-TimeoutSec=0
-
-[Install]
-WantedBy=basic.target
-WantedBy=sysinit.target