aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/runit/socklog_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/runit/socklog_2.1.0.bb')
-rw-r--r--meta/recipes-core/runit/socklog_2.1.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/runit/socklog_2.1.0.bb b/meta/recipes-core/runit/socklog_2.1.0.bb
new file mode 100644
index 0000000000..85c20d75a7
--- /dev/null
+++ b/meta/recipes-core/runit/socklog_2.1.0.bb
@@ -0,0 +1,31 @@
+# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Small and secure syslogd replacement for use with runit"
+HOMEPAGE = "http://smarden.org/socklog/"
+LICENSE = "BSD-3-Clause"
+SECTION = "base"
+
+LIC_FILES_CHKSUM = "file://package/COPYING;md5=c7a77593c4b489904800014396f3f742"
+SRC_URI = "http://smarden.org/${BPN}/${BP}.tar.gz \
+ file://cross.patch \
+"
+SRC_URI[md5sum] = "5d0e8e28c9329ad3af982c5241df9ff1"
+SRC_URI[sha256sum] = "aa869a787ee004da4e5509b5a0031bcc17a4ab4ac650c2ce8d4e488123acb455"
+
+S = "${WORKDIR}/admin/${BPN}-${PV}"
+
+do_compile() {
+ cd ${S}/src
+ echo "$CC -D_GNU_SOURCE $CFLAGS" >conf-cc
+ echo "$CC $LDFLAGS -Wl,-z -Wl,noexecstack" >conf-ld
+ oe_runmake
+}
+
+do_install() {
+ cd ${S}/src
+ install -d ${D}${bindir}
+ for f in socklog socklog-conf socklog-check uncat tryto; do
+ install -m 0755 $f ${D}${bindir}
+ done
+}