aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/psplash')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 5413b24057..2d0cae371d 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -74,12 +74,13 @@ python do_compile () {
import shutil, commands
# Build a separate executable for each splash image
+ convertscript = "%s/make-image-header.sh" % d.getVar('S', True)
destfile = "%s/psplash-poky-img.h" % d.getVar('S', True)
localfiles = d.getVar('SPLASH_LOCALPATHS', True).split()
outputfiles = d.getVar('SPLASH_INSTALL', True).split()
for localfile, outputfile in zip(localfiles, outputfiles):
if localfile.endswith(".png"):
- outp = commands.getstatusoutput('./make-image-header.sh %s POKY' % localfile)
+ outp = commands.getstatusoutput('%s %s POKY' % (convertscript, localfile))
print(outp[1])
fbase = os.path.splitext(os.path.basename(localfile))[0]
shutil.copyfile("%s-img.h" % fbase, destfile)