aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/psplash')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 482670d0b4..5413b24057 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -87,7 +87,7 @@ python do_compile () {
shutil.copyfile(localfile, destfile)
# For some reason just updating the header is not enough, we have to touch the .c
# file in order to get it to rebuild
- os.utime("psplash.c", None)
+ os.utime("%s/psplash.c" % d.getVar('S', True), None)
bb.build.exec_func("oe_runmake", d)
shutil.copyfile("psplash", outputfile)
}