aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.16.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
index 5d26f3efdc..5725e7fe07 100644
--- a/meta/recipes-core/gettext/gettext_0.16.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -95,4 +95,15 @@ do_install_append() {
rm -f ${D}${libdir}/preloadable_libintl.so
}
+# Anyone inheriting gettext will have both gettext-native and gettext
+# available, and we don't want to use older macros from the target gettext in
+# a non-gplv3 build, so kill them and let dependent recipes rely on
+# gettext-native.
+
+SYSROOT_PREPROCESS_FUNCS += "remove_sysroot_m4_macros"
+
+remove_sysroot_m4_macros () {
+ rm -r "${SYSROOT_DESTDIR}${datadir}/aclocal"
+}
+
BBCLASSEXTEND = "native nativesdk"