aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/fts
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/fts')
-rw-r--r--meta/recipes-core/fts/fts.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-core/fts/fts.bb b/meta/recipes-core/fts/fts.bb
index d8b4ed2a93..2539e5dc06 100644
--- a/meta/recipes-core/fts/fts.bb
+++ b/meta/recipes-core/fts/fts.bb
@@ -22,9 +22,15 @@ S = "${WORKDIR}/${BPN}"
do_configure[noexec] = "1"
+HASHSTYLE_mips = "sysv"
+HASHSTYLE_mipsel = "sysv"
+HASHSTYLE_mips64 = "sysv"
+HASHSTYLE_mips64el = "sysv"
+HASHSTYLE = "gnu"
+
VER = "0"
do_compile () {
- ${CC} -I${S} -fPIC -shared -o libfts.so.${VER} -Wl,-soname,libfts.so.${VER} ${S}/fts.c
+ ${CC} -I${S} -fPIC -shared -Wl,--hash-style=${HASHSTYLE} -o libfts.so.${VER} -Wl,-soname,libfts.so.${VER} ${S}/fts.c
}
do_install() {