summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dropbear/dropbear/dropbear-0.53.1-static_build_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dropbear/dropbear/dropbear-0.53.1-static_build_fix.patch')
-rw-r--r--meta/recipes-core/dropbear/dropbear/dropbear-0.53.1-static_build_fix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/dropbear/dropbear/dropbear-0.53.1-static_build_fix.patch b/meta/recipes-core/dropbear/dropbear/dropbear-0.53.1-static_build_fix.patch
new file mode 100644
index 0000000000..14a87705d0
--- /dev/null
+++ b/meta/recipes-core/dropbear/dropbear/dropbear-0.53.1-static_build_fix.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Inappropriate [Pending]
+Get this patch from buildroot maillist.
+
+dropbear: fix static build
+
+The latest release 0.53.1 change: lcrypt needs to be before object files for static linking
+
+the -lcrypt is missing during the link
+
+svr-authpasswd.o: In function `svr_auth_password':
+svr-authpasswd.c:(.text+0xfc): undefined reference to `crypt'
+collect2: ld returned 1 exit status
+
+Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj at jcrosoft.com>
+Signed-off-by: Mei Lei <lei.mei@intel.com>
+
+diff --git a/Makefile.in b/Makefile.in
+index 8d81647..0b9b769 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -77,7 +77,7 @@ STRIP=@STRIP@
+ INSTALL=@INSTALL@
+ CPPFLAGS=@CPPFLAGS@
+ CFLAGS+=-I. -I$(srcdir) $(CPPFLAGS) @CFLAGS@
+-LIBS+=@LIBS@
++LIBS+=@CRYPTLIB@ @LIBS@
+ LDFLAGS=@LDFLAGS@
+
+ EXEEXT=@EXEEXT@