aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dropbear/dropbear/0002-static_build_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dropbear/dropbear/0002-static_build_fix.patch')
-rw-r--r--meta/recipes-core/dropbear/dropbear/0002-static_build_fix.patch64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-core/dropbear/dropbear/0002-static_build_fix.patch b/meta/recipes-core/dropbear/dropbear/0002-static_build_fix.patch
deleted file mode 100644
index 552bee8996..0000000000
--- a/meta/recipes-core/dropbear/dropbear/0002-static_build_fix.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-Subject: [PATCH 2/6] static_build_fix
-Upstream-Status: Submitted
-
-dropbear: fix static build
-
-A more appropriate fix is to remove @CRYPTLIB@ from the objs
-line, since it will cause problems with target checking,
-this change also meets the goals of the orignal change which
-was to not link libcrypt to all binaries.
-
-svr-authpasswd.o: In function `svr_auth_password':
-svr-authpasswd.c:(.text+0xfc): undefined reference to `crypt'
-collect2: ld returned 1 exit status
-
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- Makefile.in | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index 4bdd845..e82e561 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -56,7 +56,7 @@ HEADERS=options.h dbutil.h session.h packet.h algo.h ssh.h buffer.h kex.h \
- loginrec.h atomicio.h x11fwd.h agentfwd.h tcpfwd.h compat.h \
- listener.h fake-rfc2553.h
-
--dropbearobjs=$(COMMONOBJS) $(CLISVROBJS) $(SVROBJS) @CRYPTLIB@
-+dropbearobjs=$(COMMONOBJS) $(CLISVROBJS) $(SVROBJS)
- dbclientobjs=$(COMMONOBJS) $(CLISVROBJS) $(CLIOBJS)
- dropbearkeyobjs=$(COMMONOBJS) $(KEYOBJS)
- dropbearconvertobjs=$(COMMONOBJS) $(CONVERTOBJS)
-@@ -158,7 +158,10 @@ dbclient: $(dbclientobjs)
- dropbearkey: $(dropbearkeyobjs)
- dropbearconvert: $(dropbearconvertobjs)
-
--dropbear dbclient dropbearkey dropbearconvert: $(HEADERS) $(LIBTOM_DEPS) Makefile
-+dropbear: $(HEADERS) $(LIBTOM_DEPS) Makefile
-+ $(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBS) @CRYPTLIB@
-+
-+dbclient dropbearkey dropbearconvert: $(HEADERS) $(LIBTOM_DEPS) Makefile
- $(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBS)
-
- # scp doesn't use the libs so is special.
-@@ -169,14 +172,14 @@ scp: $(SCPOBJS) $(HEADERS) Makefile
- # multi-binary compilation.
- MULTIOBJS=
- ifeq ($(MULTI),1)
-- MULTIOBJS=dbmulti.o $(sort $(foreach prog, $(PROGRAMS), $($(prog)objs))) @CRYPTLIB@
-+ MULTIOBJS=dbmulti.o $(sort $(foreach prog, $(PROGRAMS), $($(prog)objs)))
- CFLAGS+=$(addprefix -DDBMULTI_, $(PROGRAMS)) -DDROPBEAR_MULTI
- endif
-
- dropbearmulti: multilink
-
- multibinary: $(HEADERS) $(MULTIOBJS) $(LIBTOM_DEPS) Makefile
-- $(CC) $(LDFLAGS) -o dropbearmulti$(EXEEXT) $(MULTIOBJS) $(LIBS)
-+ $(CC) $(LDFLAGS) -o dropbearmulti$(EXEEXT) $(MULTIOBJS) $(LIBS) @CRYPTLIB@
-
- multilink: multibinary $(addprefix link, $(PROGRAMS))
-
---
-1.7.11.7
-