aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-1.2.24
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dbus/dbus-1.2.24')
-rw-r--r--meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init121
-rw-r--r--meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch56
-rw-r--r--meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch34
3 files changed, 211 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init b/meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init
new file mode 100644
index 0000000000..4abc4cbf73
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init
@@ -0,0 +1,121 @@
+#! /bin/sh
+### BEGIN INIT INFO
+# Provides: dbus
+# Required-Start: $remote_fs $syslog
+# Required-Stop: $remote_fs $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 1
+# Short-Description: D-Bus systemwide message bus
+# Description: D-Bus is a simple interprocess messaging system, used
+# for sending messages between applications.
+### END INIT INFO
+#
+# -*- coding: utf-8 -*-
+# Debian init.d script for D-BUS
+# Copyright © 2003 Colin Walters <walters@debian.org>
+
+set -e
+
+DAEMON=/usr/bin/dbus-daemon
+NAME=dbus
+DAEMONUSER=messagebus
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
+UUIDDIR=/var/lib/dbus
+DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/dbus ]; then
+ . /etc/default/dbus
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER $PIDDIR
+ chgrp $DAEMONUSER $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+
+ if [ ! -d $UUIDDIR ]; then
+ mkdir -p $UUIDDIR
+ chown $DAEMONUSER $UUIDDIR
+ chgrp $DAEMONUSER $UUIDDIR
+ fi
+
+ dbus-uuidgen --ensure
+
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ if [ -d $EVENTDIR ]; then
+ run-parts --arg=start $EVENTDIR
+ fi
+}
+
+shut_it_down()
+{
+ if [ -d $EVENTDIR ]; then
+ # TODO: --reverse when busybox supports it
+ run-parts --arg=stop $EVENTDIR
+ fi
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+reload_it()
+{
+ echo -n "Reloading $DESC config: "
+ dbus-send --print-reply --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig > /dev/null
+ # hopefully this is enough time for dbus to reload it's config file.
+ echo "done."
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ reload|force-reload)
+ reload_it
+ ;;
+ restart)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch b/meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch
new file mode 100644
index 0000000000..edb63a5faf
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch
@@ -0,0 +1,56 @@
+# Update fix-daemon-install patch to use automake magic to avoid the wrapper scripts
+#
+# original by RP, updated to handle dbus-daemon-launch-helper by Kevin Tian <kevin.tian@intel.com>, 2010-07-10
+Index: dbus-1.2.14/bus/Makefile.am
+===================================================================
+--- dbus-1.2.14.orig/bus/Makefile.am 2009-04-17 20:45:29.000000000 +0100
++++ dbus-1.2.14/bus/Makefile.am 2009-11-13 09:47:24.000000000 +0000
+@@ -149,7 +149,7 @@ endif
+
+ ## we use noinst_PROGRAMS not check_PROGRAMS so that we build
+ ## even when not doing "make check"
+-noinst_PROGRAMS=$(TESTS) dbus-daemon dbus-daemon-launch-helper-test dbus-daemon-launch-helper
++noinst_PROGRAMS=$(TESTS) dbus-daemon-launch-helper-test
+
+ bus_test_system_SOURCES= \
+ $(XML_SOURCES) \
+@@ -171,34 +171,22 @@ bus_test_SOURCES= \
+ bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
+ bus_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
++dbusdaemondir = $(DBUS_DAEMONDIR)
++dbusdaemon_PROGRAMS = dbus-daemon
++
++libexec_PROGRAMS = dbus-daemon-launch-helper
++
+ ## mop up the gcov files
+ clean-local:
+ /bin/rm *.bb *.bbg *.da *.gcov || true
+
+-uninstall-hook:
+- rm -f $(DESTDIR)$(DBUS_DAEMONDIR)/dbus-daemon
+- rm -f $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper
+-
+ install-data-hook:
+- if test '!' -d $(DESTDIR)$(DBUS_DAEMONDIR); then \
+- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
+- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
+- fi
+- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/session.d
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/system-services
+ $(mkinstalldirs) $(DESTDIR)$(libexecdir)/dbus-1
+- $(INSTALL_PROGRAM) dbus-daemon-launch-helper $(DESTDIR)$(libexecdir)
+- if test `id -u` -eq 0; then \
+- chown root:$(DBUS_USER) $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
+- chmod 4750 $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
+- else \
+- echo "Not installing $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper binary setuid!"; \
+- echo "You'll need to manually set permissions to root:$(DBUS_USER) and permissions 4750"; \
+- fi
+
+ #### Init scripts fun
+ SCRIPT_IN_FILES=messagebus.in \
diff --git a/meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch b/meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch
new file mode 100644
index 0000000000..f5c22af129
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch
@@ -0,0 +1,34 @@
+# avoid to check tmp dir at build time. instead uses hard coded /tmp here
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>
+
+--- dbus-0.22/configure.in.orig 2004-08-13 00:57:16.000000000 +0200
++++ dbus-0.22/configure.in 2004-12-30 21:15:57.000000000 +0100
+@@ -1047,15 +1048,18 @@
+ AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
+
+ #### Find socket directories
+-if ! test -z "$TMPDIR" ; then
+- DEFAULT_SOCKET_DIR=$TMPDIR
+-elif ! test -z "$TEMP" ; then
+- DEFAULT_SOCKET_DIR=$TEMP
+-elif ! test -z "$TMP" ; then
+- DEFAULT_SOCKET_DIR=$TMP
+-else
+- DEFAULT_SOCKET_DIR=/tmp
+-fi
++#if ! test -z "$TMPDIR" ; then
++# DEFAULT_SOCKET_DIR=$TMPDIR
++#elif ! test -z "$TEMP" ; then
++# DEFAULT_SOCKET_DIR=$TEMP
++#elif ! test -z "$TMP" ; then
++# DEFAULT_SOCKET_DIR=$TMP
++#else
++# DEFAULT_SOCKET_DIR=/tmp
++#fi
++
++# checks disabled to avoid expanding this at build time
++DEFAULT_SOCKET_DIR=/tmp
+
+ if ! test -z "$with_test_socket_dir" ; then
+ TEST_SOCKET_DIR="$with_test_socket_dir"