aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.2.4.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.2.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.2.4.bb b/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
new file mode 100644
index 0000000000..efa3b91c16
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Multipurpose relay for bidirectional data transfer"
+DESCRIPTION = "Socat is a relay for bidirectional data \
+transfer between two independent data channels."
+HOMEPAGE = "http://www.dest-unreach.org/socat/"
+
+SECTION = "console/network"
+
+DEPENDS = "openssl readline"
+
+LICENSE = "GPL-2.0+-with-OpenSSL-exception"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://README;beginline=257;endline=287;md5=79246f11a1db0b6ccec54d1fb711c01e"
+
+
+SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
+ file://fix-cross-compiling-failed.patch \
+"
+
+SRC_URI[md5sum] = "69b8155dd442a6f24e28ef5407d868eb"
+SRC_URI[sha256sum] = "4b7739901c6fad1e460f3e5b1868fb4c2a1427febbba7a510cd2e42fd4941e09"
+
+inherit autotools
+
+EXTRA_AUTORECONF += "--exclude=autoheader"
+
+EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \
+ sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \
+ ac_cv_ispeed_offset=13 \
+"
+
+PACKAGECONFIG ??= "tcp-wrappers"
+PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
+
+do_install_prepend () {
+ mkdir -p ${D}${bindir}
+ install -d ${D}${bindir} ${D}${mandir}/man1
+}