aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/socat/socat')
-rw-r--r--meta/recipes-connectivity/socat/socat/fix-cross-compiling-failed.patch36
-rw-r--r--meta/recipes-connectivity/socat/socat/socat-1.7.2.4-linux-3.17.patch29
2 files changed, 0 insertions, 65 deletions
diff --git a/meta/recipes-connectivity/socat/socat/fix-cross-compiling-failed.patch b/meta/recipes-connectivity/socat/socat/fix-cross-compiling-failed.patch
deleted file mode 100644
index b9d3ca3bab..0000000000
--- a/meta/recipes-connectivity/socat/socat/fix-cross-compiling-failed.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Fix build during cross-compilation as it fails to detect that our prefixed
-compiler is gcc, and falls back to executing code to determine type sizes:
-
-| configure: using code run method to find basic types
-| checking for equivalent simple type of size_t...
-| configure: error: in `/data/poky-master/tmp/work/core2-32-poky-linux/socat/1.7.2.4-r0/build':
-| configure: error: cannot run test program while cross compiling
-
-This is caused by configure.in assuming that $CC can be literally compared with
-"gcc" to determine if the compiler is GCC. Our gcc is host-prefixed so this
-test fails, however autoconf provides $GCC for this purpose (which was used up
-to 1.7.2.3).
-
-Upstream-Status: Submitted (via email)
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
----
- configure.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.in b/configure.in
---- a/configure.in
-+++ b/configure.in
-@@ -41,7 +41,7 @@ AC_CHECK_PROG(AR, ar, ar, gar)
- # fail
- AC_LANG_COMPILER_REQUIRE()
-
--if test "$CC" = "gcc"; then
-+if test "$GCC" = yes; then
- CFLAGS="$CFLAGS -D_GNU_SOURCE -Wall -Wno-parentheses"
- ERRONWARN="-Werror -O0"
- elif test "$CC" = "clang"; then
---
-1.8.1.2
-
diff --git a/meta/recipes-connectivity/socat/socat/socat-1.7.2.4-linux-3.17.patch b/meta/recipes-connectivity/socat/socat/socat-1.7.2.4-linux-3.17.patch
deleted file mode 100644
index 9152df533f..0000000000
--- a/meta/recipes-connectivity/socat/socat/socat-1.7.2.4-linux-3.17.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-socat: fix compile erorr against 3.17+ kernel headers
-
-With the linux 3.17 kernel socat's configure detects the wrong include for errqueue.h
-which results in a compilation error.
-
-By backporting the gentoo patch from:
-
- http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch
-
-Fixes the build issue
-
-Upstream-status: backport
-
-Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-
---- a/configure.in
-+++ b/configure.in
-@@ -80,7 +80,10 @@
- AC_CHECK_HEADERS(termios.h linux/if_tun.h)
- AC_CHECK_HEADERS(net/if_dl.h)
- AC_CHECK_HEADERS(linux/types.h)
--AC_CHECK_HEADER(linux/errqueue.h, AC_DEFINE(HAVE_LINUX_ERRQUEUE_H), [], [#include <linux/types.h>])
-+AC_CHECK_HEADER(linux/errqueue.h, AC_DEFINE(HAVE_LINUX_ERRQUEUE_H), [], [AC_INCLUDES_DEFAULT
-+ #if HAVE_LINUX_TYPES_H
-+ #include <linux/types.h>
-+ #endif])
- AC_CHECK_HEADERS(sys/utsname.h sys/select.h sys/file.h)
- AC_CHECK_HEADERS(util.h bsd/libutil.h libutil.h sys/stropts.h regex.h)
- AC_CHECK_HEADERS(linux/fs.h linux/ext2_fs.h)