aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ofono
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/ofono')
-rw-r--r--meta/recipes-connectivity/ofono/files/ofono42
-rw-r--r--meta/recipes-connectivity/ofono/ofono.inc16
-rw-r--r--meta/recipes-connectivity/ofono/ofono_0.17.bb7
-rw-r--r--meta/recipes-connectivity/ofono/ofono_git.bb13
4 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ofono/files/ofono b/meta/recipes-connectivity/ofono/files/ofono
new file mode 100644
index 0000000000..6d46fb8966
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/files/ofono
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/ofonod
+PIDFILE=/var/run/ofonod.pid
+DESC="Telephony daemon"
+
+if [ -f /etc/default/ofono] ; then
+ . /etc/default/ofono
+fi
+
+set -e
+
+do_start() {
+ $DAEMON
+}
+
+do_stop() {
+ start-stop-daemon --stop --name ofonod --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/meta/recipes-connectivity/ofono/ofono.inc b/meta/recipes-connectivity/ofono/ofono.inc
new file mode 100644
index 0000000000..8948e57ae7
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono.inc
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://www.ofono.org"
+SUMMARY = "open source telephony"
+LICENSE = "GPL"
+
+inherit autotools pkgconfig update-rc.d
+
+DEPENDS = "dbus glib-2.0"
+
+INITSCRIPT_NAME = "ofono"
+INITSCRIPT_PARAMS = "defaults 22"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
+}
+
diff --git a/meta/recipes-connectivity/ofono/ofono_0.17.bb b/meta/recipes-connectivity/ofono/ofono_0.17.bb
new file mode 100644
index 0000000000..02b64e5b28
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono_0.17.bb
@@ -0,0 +1,7 @@
+require ofono.inc
+
+PR = "r0"
+
+SRC_URI = "http://www.kernel.org/pub/linux/network/ofono/${P}.tar.bz2 \
+ file://ofono"
+
diff --git a/meta/recipes-connectivity/ofono/ofono_git.bb b/meta/recipes-connectivity/ofono/ofono_git.bb
new file mode 100644
index 0000000000..3e2c4108cf
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono_git.bb
@@ -0,0 +1,13 @@
+require ofono.inc
+
+S = "${WORKDIR}/git"
+PV = "0.12-git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.kernel.org/pub/scm/network/ofono/ofono.git;protocol=git \
+ file://ofono"
+
+do_configure_prepend () {
+ ${S}/bootstrap
+}
+