aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind-9.7.2-P2/cross-build-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/bind/bind-9.7.2-P2/cross-build-fix.patch')
-rw-r--r--meta/recipes-connectivity/bind/bind-9.7.2-P2/cross-build-fix.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind-9.7.2-P2/cross-build-fix.patch b/meta/recipes-connectivity/bind/bind-9.7.2-P2/cross-build-fix.patch
new file mode 100644
index 0000000000..4978379bff
--- /dev/null
+++ b/meta/recipes-connectivity/bind/bind-9.7.2-P2/cross-build-fix.patch
@@ -0,0 +1,19 @@
+11/30/2010
+gen.c should be build by ${BUILD_CC}
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/lib/export/dns/Makefile.in b/lib/export/dns/Makefile.in
+index aeadf57..d3fae74 100644
+--- a/lib/export/dns/Makefile.in
++++ b/lib/export/dns/Makefile.in
+@@ -166,7 +166,8 @@ code.h: gen
+ ./gen -s ${srcdir} > code.h
+
+ gen: ${srcdir}/gen.c
+- ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
++ ${BUILD_CC} ${BUILD_CFLAGS} -I${top_srcdir}/lib/isc/include \
++ ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} -o $@ ${srcdir}/gen.c ${BUILD_LIBS}
+
+ #We don't need rbtdb64 for this library
+ #rbtdb64.@O@: rbtdb.c