aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/pciutils/pciutils/configure.patch12
-rw-r--r--meta/recipes-bsp/pciutils/pciutils/guess-fix.patch12
2 files changed, 2 insertions, 22 deletions
diff --git a/meta/recipes-bsp/pciutils/pciutils/configure.patch b/meta/recipes-bsp/pciutils/pciutils/configure.patch
index 66c9f91630..c87b3500f2 100644
--- a/meta/recipes-bsp/pciutils/pciutils/configure.patch
+++ b/meta/recipes-bsp/pciutils/pciutils/configure.patch
@@ -80,7 +80,7 @@ diff -r af2b10cc3c14 lib/configure
fi
[ -n "$RELEASE" ] && rel="${RELEASE}"
# CAVEAT: tr on Solaris is a bit weird and the extra [] is otherwise harmless.
-@@ -49,6 +53,21 @@
+@@ -49,6 +53,11 @@
sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'`
echo " $host $rel $cpu $sys"
@@ -89,16 +89,6 @@ diff -r af2b10cc3c14 lib/configure
+ sys=linux
+fi
+
-+if [ "$host" = "linux--uclibc" ]
-+then
-+ sys=linux
-+fi
-+
-+if [ "$host" = "linux--uclibceabi" ]
-+then
-+ sys=linux
-+fi
-+
c=config.h
m=config.mk
echo >$c '#define PCI_CONFIG_H'
diff --git a/meta/recipes-bsp/pciutils/pciutils/guess-fix.patch b/meta/recipes-bsp/pciutils/pciutils/guess-fix.patch
index 540b4a0d13..f918e3bdc3 100644
--- a/meta/recipes-bsp/pciutils/pciutils/guess-fix.patch
+++ b/meta/recipes-bsp/pciutils/pciutils/guess-fix.patch
@@ -13,7 +13,7 @@ diff --git a/lib/configure b/lib/configure
index 4318b05..84f6acb 100755
--- a/lib/configure
+++ b/lib/configure
-@@ -53,20 +53,7 @@ cpu=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\1/'`
+@@ -53,10 +53,7 @@ cpu=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\1/'`
sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'`
echo " $host $rel $cpu $sys"
@@ -21,16 +21,6 @@ index 4318b05..84f6acb 100755
-then
- sys=linux
-fi
--
--if [ "$host" = "linux--uclibc" ]
--then
-- sys=linux
--fi
--
--if [ "$host" = "linux--uclibceabi" ]
--then
-- sys=linux
--fi
+{ echo "$host" | grep linux; } && sys=linux
c=config.h