aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/selftest/oescripts.py
diff options
context:
space:
mode:
Diffstat (limited to 'meta/lib/oeqa/selftest/oescripts.py')
-rw-r--r--meta/lib/oeqa/selftest/oescripts.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/lib/oeqa/selftest/oescripts.py b/meta/lib/oeqa/selftest/oescripts.py
index 28345dc6a2..baf3b6ab2c 100644
--- a/meta/lib/oeqa/selftest/oescripts.py
+++ b/meta/lib/oeqa/selftest/oescripts.py
@@ -14,10 +14,10 @@ class TestScripts(oeSelfTest):
@testcase(300)
def test_cleanup_workdir(self):
- path = os.path.dirname(get_bb_var('WORKDIR', 'gzip'))
- old_version_recipe = os.path.join(get_bb_var('COREBASE'), 'meta/recipes-extended/gzip/gzip_1.3.12.bb')
- old_version = '1.3.12'
- bitbake("-c clean gzip")
+ path = os.path.dirname(get_bb_var('WORKDIR', 'selftest-ed'))
+ old_version_recipe = os.path.join(get_bb_var('COREBASE'), 'meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb')
+ old_version = '0.5'
+ bitbake("-c clean selftest-ed")
bitbake("-c clean -b %s" % old_version_recipe)
if os.path.exists(path):
@@ -25,7 +25,7 @@ class TestScripts(oeSelfTest):
else:
initial_contents = []
- bitbake('gzip')
+ bitbake('selftest-ed')
intermediary_contents = os.listdir(path)
bitbake("-b %s" % old_version_recipe)
runCmd('cleanup-workdir')