aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rt')
-rw-r--r--meta-rt/conf/layer.conf3
-rw-r--r--meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb3
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-rt/conf/layer.conf b/meta-rt/conf/layer.conf
index dbf4a326ba..94ebc02520 100644
--- a/meta-rt/conf/layer.conf
+++ b/meta-rt/conf/layer.conf
@@ -17,6 +17,7 @@ BBFILE_PRIORITY_rt = "8"
PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt"
# preempt_rt SRCREVs, one for meta, one per machine
-SRCREV_meta_pn-linux-yocto-rt ?= "50ccd2b3213b6a1bacb3f898c035119802dac420"
+SRCREV_meta_pn-linux-yocto-rt ?= "b0615811ce38836d1ade230e3bdb1efaaa68471f"
SRCREV_machine_pn-linux-yocto-rt_qemux86-64 ?= "f49444f06875894389e640bcda6c3f6ceb1f0c3e"
+SRCREV_machine_pn-linux-yocto-rt_atom-pc ?= "78dacaf8222c9492ba17f652989ef3466423bdc2"
diff --git a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
index 361b6806cd..547f8feac3 100644
--- a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
+++ b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
@@ -2,6 +2,7 @@ inherit kernel
require recipes-kernel/linux/linux-yocto.inc
KMACHINE_qemux86-64 = "common_pc_64"
+KMACHINE_atom-pc = "atom-pc"
LINUX_VERSION ?= "2.6.34"
LINUX_KERNEL_TYPE = "preempt_rt"
@@ -11,7 +12,7 @@ PR = "r0"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRCREV_FORMAT = "meta_machine"
-COMPATIBLE_MACHINE = "(qemux86-64)"
+COMPATIBLE_MACHINE = "(qemux86-64|atom-pc)"
# this performs a fixup on the SRCREV for new/undefined BSPs
python __anonymous () {