summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/vincent/vincent_svn.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-extras/packages/vincent/vincent_svn.bb b/meta-extras/packages/vincent/vincent_svn.bb
new file mode 100644
index 0000000000..8eafde7470
--- /dev/null
+++ b/meta-extras/packages/vincent/vincent_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Vincent OpenGL-ES library "
+HOMEPAGE = "http://sourceforge.net/projects/ogl-es/"
+LICENSE = "BSD"
+
+PV = "0.0+svn${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=ogles;proto=http"
+S = "${WORKDIR}/ogles/"
+
+inherit autotools pkgconfig
+
+# PACKAGES = ${PN}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/GLES
+
+ install -m 0644 ${S}/include/ug.h ${STAGING_INCDIR}
+ install -m 0644 ${S}/include/GLES/* ${STAGING_INCDIR}/GLES/
+
+ oe_libinstall -so libvincent ${STAGING_LIBDIR}
+}