summaryrefslogtreecommitdiffstats
path: root/bitbake/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake/ChangeLog')
-rw-r--r--bitbake/ChangeLog19
1 files changed, 18 insertions, 1 deletions
diff --git a/bitbake/ChangeLog b/bitbake/ChangeLog
index 3dfba1ed81..93cc45aaf4 100644
--- a/bitbake/ChangeLog
+++ b/bitbake/ChangeLog
@@ -1,9 +1,26 @@
-Changes in BitBake 1.3.x:
+Changes in BitBake 1.4.2:
+ - Send logs to oe.pastebin.com instead of pastebin.com
+ fixes #856
+ - Copy the internal bitbake data before building the
+ dependency graph. This fixes nano not having a
+ virtual/libc dependency
+ - Allow multiple TARBALL_STASH entries
+ - Cache, check if the directory exists before changing
+ into it
+ - git speedup cloning by not doing a checkout
+ - allow to have spaces in filenames (.conf, .bb, .bbclass)
+
+Changes in BitBake 1.4.0:
- Fix to check both RDEPENDS and RDEPENDS_${PN}
- Fix a RDEPENDS parsing bug in utils:explode_deps()
- Update git fetcher behaviour to match git changes
- ASSUME_PROVIDED allowed to include runtime packages
- git fetcher cleanup and efficency improvements
+ - Change the format of the cache
+ - Update usermanual to document the Fetchers
+ - Major changes to caching with a new strategy
+ giving a major performance increase when reparsing
+ with few data changes
Changes in BitBake 1.3.3:
- Create a new Fetcher module to ease the