summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/conf/bitbake.conf2
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index b6aa9f33e9..f7544b35c6 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -488,7 +488,7 @@ HOSTTOOLS += " \
cpp cut date dd diff diffstat dirname du echo egrep env expand expr false \
fgrep file find flock g++ gawk gcc getconf getopt git grep gunzip gzip \
head hostname iconv id install ld ldd ln ls make makeinfo md5sum mkdir mknod \
- mktemp mv nm objcopy objdump od patch perl pod2man pr printf pwd \
+ mktemp mv nm objcopy objdump od patch perl pr printf pwd \
python3 ranlib readelf readlink realpath rm rmdir rpcgen sed seq sh sha256sum \
sleep sort split stat strings strip tail tar tee test touch tr true uname \
uniq wc wget which xargs \
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
index 6495726500..8e7ef00b08 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
@@ -18,6 +18,8 @@ TARGET_CC_ARCH += "${LDFLAGS}"
RDEPENDS_${PN} += "bash"
+inherit perlnative
+
# For native builds we use the host Python
PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
PYTHONRDEPS_class-native = ""